PHP5

PHP5

Postby jerboa » Mon Aug 15, 2005 3:18 pm

Just wondering what your plans are to move to PHP5...

Thanks in advance!

J
jerboa
 
Posts: 1
Joined: Mon Aug 15, 2005 3:16 pm

Postby admin » Tue Aug 16, 2005 4:56 pm

We've been eyeing it for awhile but until everything is fully compatible with PHP5 we wont make that change just yet.

I've also heard that some software packages didnt work well with PHP5 unless there were some small changes done to the coding, ie. oscommerce.

We might try it on some new servers but dont feel like rockin the boat too hard on the existing servers and break everyones shopping carts until we're 100% sure.

:wink:

Al.
admin
Site Admin
 
Posts: 36
Joined: Fri Dec 10, 2004 11:59 am

Postby Drac » Mon Oct 03, 2005 5:26 pm

If you compile it with php4 compat. on everything should work fine.
Drac
 
Posts: 3
Joined: Mon Oct 03, 2005 5:25 pm

phpwebsite is not compatible either

Postby MikeyCarter » Wed Feb 01, 2006 10:08 pm

You can add phpwebsite to the list of php5 non-compatible.

I run fedora core 4 and there are quite a few module which don't work in php5. The main one being the user module which controls the entire site security.
Going to or having a Garage Sale?
Try http://garagesale.carterfamily.ca to help you plot your route.

Have a joke or story to share?
Try http://theshadow.carterfamily.ca (The Shadow Writing Centre) to post your work.
MikeyCarter
 
Posts: 8
Joined: Mon Jan 02, 2006 8:16 pm
Location: Orangeville, ON

Postby Kyle » Sun Jun 11, 2006 8:01 pm

I am wondering the same question. I won't be buying hosting until and unless PHP 5 is supported.
Kyle
 
Posts: 1
Joined: Sun Jun 11, 2006 7:58 pm

Postby NJ » Mon Jul 10, 2006 4:44 pm

Don't you think you've been "eyeing" it long enough?
I have 2 clients who want support for uploading images to the internet and I'd like to use the PHP EXIF Library to gather information about the images when they are uploaded. All 3 available versions of this library (7, 8 and 9) only work with PHP 5.
Other web hosts offer the option of PHP 4 or PHP 5 couldn't you do that? If not, I will have to send my clients to another web host.
NJ
 
Posts: 1
Joined: Mon Jul 10, 2006 4:36 pm
Location: Gibsons, BC

Postby shivin » Mon Oct 02, 2006 1:28 am

Some of our servers are already having php5.
We are in the process of enabling it on the rest of the servers too.
Please send in a support ticket, so that we shall move your account to one of the servers which already have php5
shivin
 

Re: PHP5

Postby Proventus » Mon Apr 19, 2010 7:01 pm

by admin » Tue Aug 16, 2005 4:56 pm

We've been eyeing it for awhile but until everything is fully compatible with PHP5 we wont make that change just yet.

I've also heard that some software packages didnt work well with PHP5 unless there were some small changes done to the coding, ie. oscommerce.

We might try it on some new servers but dont feel like rockin the boat too hard on the existing servers and break everyones shopping carts until we're 100% sure.



Al.


I hate like hell to rush you guys but holly crap! 2005??? Do you know the grief you are causing those of us with clients by not upgrading to PHP5? If this isn't done soon, like REAL soon, I'm moving my clients off.
Proventus
 
Posts: 1
Joined: Mon Apr 19, 2010 6:52 pm

Re: PHP5

Postby kevin » Sat May 29, 2010 10:20 pm

There are some older servers with PHP 4 as customers need this or else their scripts break. If you are on one of these servers, contact us and we can move you out.
kevin
CWH Staff
 
Posts: 245
Joined: Mon Dec 13, 2004 12:48 pm
Location: Vancouver, BC

Running Supported version of PHP (wasRe: PHP5)

Postby admiral » Sun Sep 11, 2011 11:36 am

I see this issue is as old as the hills.

The current site is running 5.2.17 but this is not a supported version. The 5.3 series has been out for
a couple of years. It a least should be made available.

I understand that users install tools and libraries that depend on older versions.

This just implies the feature that should be supported is MULTIPLE PHP releases with some
reasonable restrictions. Something like the latest version of the last release and a stable version of
the current series that is no older than one year. That would mean we would be running
at least 5.3.5 which fixed a critical vulnerability.

And would be an option to run the latest release complete client supported. If I want to
work without a net I will take on that responsibility. Hey I might even pay for the privilege.
admiral
 
Posts: 2
Joined: Sun Sep 11, 2011 8:30 am


Return to PHP

Who is online

Users browsing this forum: Bing [Bot] and 0 guests

cron